Version 0.8.1 Released

Posted
M@
on 06.29.2007, tagged: releases. .

I know it's been a long time coming, but here it is: Comatose 0.8.1!

Over the next few days, I'll be transitioning from RubyForge over to Google Code and Google Groups please start using them for reporting bugs and such.

Here are the important URLs:

I've also updated the docs to reflect the new 0.8+ way of doing things. They'll wind up on the wiki so that they'll be easily maintained by all.

From the changelog:

  • All includes and helpers are loaded at the end of the ComatoseController and ComatoseAdminController classes
  • Fixed the ComatoseController#show action to correctly send an HTTP status of 404 even if it finds, and renders, a page at '/404'
  • Fixed the migration to default a page's full_path to '' instead of null
  • Formalized ComatoseDrops. Use Comatose.define_drop "drop_name", do ... end. Every method within that block should return a value for use with a Liquid and/or ERB template. Usage in a comatose page: {{ drop_name.def_name }}
  • Added support for a config.after_setup block that gets called after Comatose is setup (in the Dispatcher#to_prepare event)
  • Added HTML comment output for calls that result in a method_missing on the ProcessingContext
  • Updated page tree to remember collapsed/expanded nodes between page visits
  • Fixed some errors that were caused by null revisions (usually happened after initial installation)
  • Added my javascript test_runner lib for testing slugs generated by JavaScript. More JS tests to come.
  • Bugfix #8640 (rubyforge bug)

And from Version 0.8 (the version before):

  • Now ONLY supports Rails 1.2 (not even tested in Rails 1.1)
  • New configuration system
  • DEFER_COMATOSE_LOAD is gone -- Using Dispatcher.to_prepare replaces it
  • You no longer extend the base classes to add functionality. You configure Comatose to include modules and send it symbols for providing said functionality. e.g. Comatose.config.includes << :authentication_system; Comatose.config.authorization = :require_login
  • The automatic loading of RAILS_ROOT/lib/comatose/*.rb files is NO longer supported.
  • In addition to mapping comatose_root in your routes.rb, you'll want to map.comatose_admin as well
« DevSite Updated | Main | Comatose v2 Beta »